Autore Topic: Errore non mi riconosce classe Fragment  (Letto 416 volte)

Offline felasandroid

  • Utente normale
  • ***
  • Post: 345
  • Respect: +10
    • Github
    • balduzziantonio
    • balduzziantonio.unifi
    • Mostra profilo
  • Dispositivo Android:
    Huawei P8 Lite
  • Play Store ID:
    FelasTech
  • Sistema operativo:
    Windows 10
Errore non mi riconosce classe Fragment
« il: 15 Gennaio 2014, 11:31:52 CET »
0
In pratica ho creato una classe che estende Fragment ecco il codice:

Codice (Java): [Seleziona]
public class Headers extends Fragment{
       
        public Headers(){}
       
        public static final String ROW_ID1 = "row_id1";
    private ArrayList<String> Data= new ArrayList<String>();

       
        @Override
    public View onCreateView(LayoutInflater inflater, ViewGroup container,
            Bundle savedInstanceState) {
 
        View rootView = inflater.inflate(R.layout.layout_header_tab, container, false);
       
       
        Data = (ArrayList<String>)   this.getActivity().getIntent().getExtras().get(ROW_ID1);
        TextView responseView = new TextView(getActivity());
        responseView = (TextView) rootView.findViewById(R.id.textHeaderView);

     
        for(int i=0; i< Data.size();i++){
         
                responseView.append(Data.get(i));
                responseView.append("\n");
         
      }
       
        return rootView;
    }

}

solo che nell'activity principale quando la richiamo, cioè:

Codice (Java): [Seleziona]
private void displayView(int position) {
                // update the main content by replacing fragments
                Fragment fragment = null;
                switch (position) {
                case 0:
                        fragment = new WebSource();
                        break;
                case 1:
                        fragment = new Headers();
                        break;

Mi mette errore e mi dice di cambiare Fragment con Headers..

Post unito: 15 Gennaio 2014, 11:39:22 CET
Edit: controllo le librerie se sono ok

Post unito: 15 Gennaio 2014, 11:46:13 CET
c'era un errore di importazione di una libreria..tutto ok
« Ultima modifica: 15 Gennaio 2014, 11:46:13 CET da felasandroid, Reason: Merged DoublePost »