Autore Topic: Prima applicazione con qualche problema.  (Letto 552 volte)

Offline x69asterix

  • Nuovo arrivato
  • *
  • Post: 2
  • Respect: 0
    • Mostra profilo
Prima applicazione con qualche problema.
« il: 10 Dicembre 2013, 16:20:16 CET »
0
Premetto che è da poco tempo che sto cominciando a giocare un po con questo ambiente di sviluppo.
Come posso impostare di default un'activity?
Mi spiego meglio in una mia applicazione, ho tre activity, alla prima esecuzione tutto bene mi visualizza la pagina di default, ma se ad esempio esco dalla terza ativity, quando la eseguo, mi aspetto che mi lanci l'activity di default, invece l'applicazione mi viene eseguita dall'ultima activity e non mai da quella di default.
E un bug o sicuramente sbaglio qualcosa-.
Per lo sviluppo uso  Android Studio (0.36)

Offline kalacta269

  • Utente normale
  • ***
  • Post: 152
  • Respect: +14
    • Mostra profilo
  • Dispositivo Android:
    Asus Transformer pad tf300
  • Sistema operativo:
    windows7
Re:Prima applicazione con qualche problema.
« Risposta #1 il: 10 Dicembre 2013, 18:14:58 CET »
0
Se ho ben capito quando esci da un activity premendo il tasto home del dispositivo e poi riapri l'app ti porta all'ultima activity dov'eri e non a quella di default giusto? bhe è normale android funziona cosi finche ha memoria salvo lo stato dell'app nello stack quindi non c'è nessun tipo di bug....

Offline x69asterix

  • Nuovo arrivato
  • *
  • Post: 2
  • Respect: 0
    • Mostra profilo
Re:Prima applicazione con qualche problema.
« Risposta #2 il: 11 Dicembre 2013, 07:21:39 CET »
0
Ok, adesso ho capito.
Certo però che e un po strano, cioè se lancio una app, mi aspetto che questa parte dalla pagina di default, altrimenti che senso ha in fase di sviluppo impostare un' activity di default.
Devo inventare qualche stratagemma.

Offline kalacta269

  • Utente normale
  • ***
  • Post: 152
  • Respect: +14
    • Mostra profilo
  • Dispositivo Android:
    Asus Transformer pad tf300
  • Sistema operativo:
    windows7
Re:Prima applicazione con qualche problema.
« Risposta #3 il: 11 Dicembre 2013, 08:59:14 CET »
0
Ok, adesso ho capito.
Certo però che e un po strano, cioè se lancio una app, mi aspetto che questa parte dalla pagina di default, altrimenti che senso ha in fase di sviluppo impostare un' activity di default.
Devo inventare qualche stratagemma.

funziona per tutte le app prova pure con le altre app che hai sul device a fare la stessa cosa...