Autore Topic: Impostazioni corrette per creare applicazione con ADT Eclipse  (Letto 1034 volte)

Offline roccia80

  • Utente junior
  • **
  • Post: 89
  • Respect: 0
    • Mostra profilo
Impostazioni corrette per creare applicazione con ADT Eclipse
« il: 24 Ottobre 2010, 17:43:02 CEST »
0
Ciao Ragazzi,

dopo vari test e prove, sto creando una prima applicazione "seria" per Android, attraverso l'utilizzo di ADT di Eclipse.
In fase di creazione del progetto, quali sono i parametri giusti da scegliere nelle voci Build Target (per intenderci quella contenente l'elenco delle diverse versioni di androi e google api) e nel campo Min SDK version, in modo tale che l'applicazione possa girare regolarmente e senza problemi sui cellulari attualmente in circolazione?
Inoltre, tali applicazioni possono girare automaticamente anche sul GalaxyTab (con effetti grafici tutti da valutare) oppure servono parametri di progetto diversi?

Grazie
Ciao

Offline JD

  • Amministratore
  • Utente storico
  • *****
  • Post: 1600
  • Respect: +232
    • leinardi
    • Mostra profilo
  • Dispositivo Android:
    LG Nexus 5
  • Sistema operativo:
    L'ultima Ubuntu
Re:Impostazioni corrette per creare applicazione con ADT Eclipse
« Risposta #1 il: 24 Ottobre 2010, 18:35:54 CEST »
0
Nella scelta del Build Target entrano in gioco tanti fattori e circolano opinioni molto diverse su quale sia meglio utilizzare.

Ti posso dire come mi comporto io: se la tua applicazione non utilizza API particolari, che sono state modificate o introdotte dopo l'uscita dell'SDK 4 (Android 1.6), io ti consiglio di utilizzare come Build Target l'8 (Android 2.2), così da poter dare la possibilità all'utente di spostare l'applicazione sulla SD, e di indicare come MinSDK 4 (Android 1.6).

Riguardo al GalaxyTab, non mi sono ancora informato bene, ma credo che se non indichi esplicitamente nel manifest che la tua applicazione NON è copatibile, si dovrebbe poter installare senza problemi. Ovviamente devi tener conto, quando realizzi il layout, della visualizzazione su un display con una risoluzione del Galaxy Tab.
È stata trovata una soluzione al tuo problema?
Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato ;).
E se hai aperto tu il thread marcalo come risolto cliccando !

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Impostazioni corrette per creare applicazione con ADT Eclipse
« Risposta #2 il: 24 Ottobre 2010, 20:18:20 CEST »
0
Inoltre, tali applicazioni possono girare automaticamente anche sul GalaxyTab (con effetti grafici tutti da valutare) oppure servono parametri di progetto diversi?

Per il Galaxy Tab la Samsung ha rilasciato un emulatore dedicato, da usare in Eclipse proprio come tutti gli altri.

Ho da poco aggiornato il thread dove si spiega come installarlo, così puoi provare direttamente : Predisporre un'app per il Samsung Galaxy Tab - Android Developers Italia
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline roccia80

  • Utente junior
  • **
  • Post: 89
  • Respect: 0
    • Mostra profilo
Re:Impostazioni corrette per creare applicazione con ADT Eclipse
« Risposta #3 il: 25 Ottobre 2010, 19:25:10 CEST »
0
Grazie!