Autore Topic: App non compatibile con tab 2  (Letto 530 volte)

Offline gabric

  • Utente senior
  • ****
  • Post: 615
  • Respect: +18
    • Google+
    • Mostra profilo
    • Brancato's site
  • Dispositivo Android:
    Nexus 5 / Tablet mediacom s4
  • Play Store ID:
    Brancato's+app
  • Sistema operativo:
    window7. ubuntu
App non compatibile con tab 2
« il: 22 Settembre 2013, 17:58:53 CEST »
0
salve, dopo il caricamento sul market, l'app non risulta compatibile con il tab 2
nel manifest chiedo diversi permessi, ma dovrebbero essere tutti supportati dal tab, tranne action_call che ho messo "required false" (App non supportata su Galaxy Tab 2 - Android Developers Italia)
idee del perchè non è compatibile?
ecco un estratto dal manifest
Codice (XML): [Seleziona]
<uses-feature android:glEsVersion="0x00020000" android:required="true"/>
    <uses-permission android:name="android.permission.VIBRATE" />
    <uses-permission android:name="android.permission.RECEIVE_BOOT_COMPLETED" />
   
     <uses-permission android:name="android.permission.INTERNET" />
    <uses-permission android:name="android.permission.CALL_PHONE"  android:required="false" />
    <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"/>
    <uses-permission android:name="com.google.android.providers.gsf.permission.READ_GSERVICES" android:required="false"/>
     <uses-permission android:name="android.permission.WAKE_LOCK" />
      <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
     
    <uses-sdk
       android:minSdkVersion="8"
       android:targetSdkVersion="17" />

Offline Tizionario

  • Nuovo arrivato
  • *
  • Post: 30
  • Respect: +1
    • Github
    • Google+
    • tizionario
    • tizionario
    • Mostra profilo
    • Svappdroid
  • Dispositivo Android:
    Samsung Galaxy Nexus
  • Play Store ID:
    Tizionario
  • Sistema operativo:
    ArchLinux
Re:App non compatibile con tab 2
« Risposta #1 il: 08 Ottobre 2013, 12:03:10 CEST »
0
L'unica cosa che mi lascia perplesso è
Codice (XML): [Seleziona]
<uses-permission android:name="android.permission.CALL_PHONE"  android:required="false" />ma avendolo messo come permesso facoltativo dovrebbe andare comunque sui Tab2....hai per caso usato anche il tag supports-screen?
Vuoi diventare uno sviluppatore Android? Segui i miei tutorial su http://svappdroid.com

Offline gabric

  • Utente senior
  • ****
  • Post: 615
  • Respect: +18
    • Google+
    • Mostra profilo
    • Brancato's site
  • Dispositivo Android:
    Nexus 5 / Tablet mediacom s4
  • Play Store ID:
    Brancato's+app
  • Sistema operativo:
    window7. ubuntu
Re:App non compatibile con tab 2
« Risposta #2 il: 08 Ottobre 2013, 15:37:15 CEST »
0
ho risolto, ho messo le risoluzioni di schermo supportate