Autore Topic: App con webView [RISOLTO]  (Letto 524 volte)

Offline Andrea Di Lello

  • Nuovo arrivato
  • *
  • Post: 13
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Win 7
App con webView [RISOLTO]
« il: 20 Agosto 2013, 15:00:35 CEST »
0
Ciao a tutti per esercizio ho fatto un' app con una semplice webview che carica una pagina,

non ho errori/eccezioni di sorta, parte tutto sull'emulatore solo che riesce a caricare solo bing.com, provato google e altri 2 siti a caso ma non li carica, carica solo bing e tra l'altro solo la pagina iniziale, una ricerca qualsiasi da solo pagina non trovata.

avete idea di come mai ?

Read you soon

EDIT: aggiungo il codice e le specifiche dell'emulatore, premetto anche che lavoro su una VM quindi la scheda grafica è quello che è...

Codice: [Seleziona]
package com.example.protobrowser;

import android.os.Bundle;
import android.app.Activity;
import android.webkit.WebView;

public class MainBrowser extends Activity {
       
        WebView pagina;

        @Override
        protected void onCreate(Bundle savedInstanceState) {
                super.onCreate(savedInstanceState);
                setContentView(R.layout.activity_main_browser);
               
                pagina = (WebView) findViewById(R.id.webView1);
                pagina.loadUrl("https://bing.com");

        }
}

emulatore:

Andrea

Post unito: 21 Agosto 2013, 11:34:12 CEST
pare che usando un altro emulatore (senza flaggare scale size)

il browser nel webView funzioni correttamente, ho usato questo:
« Ultima modifica: 21 Agosto 2013, 11:34:12 CEST da Andrea Di Lello, Reason: Merged DoublePost »