Autore Topic: navigation drawer per api 8  (Letto 370 volte)

Offline darko

  • Nuovo arrivato
  • *
  • Post: 26
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy s4
  • Sistema operativo:
    Windows 7
navigation drawer per api 8
« il: 10 Giugno 2013, 22:51:57 CEST »
0
io ho già visto questo topic [facile] come utilizzare il nuovo Navigation Drawer - Android Developers Italia ma non capisco come implementare il navigation drawer su android 2.2 ovvero api 8...la guida parla di minsdk 8 ma se lo inserisci nell'emulatore con api 8 dà errore, e infatti dopo in una risposta hanno scritto che serve cambiare qualcosa: io non ho capito cosa, qualcuno potrebbe mostrare solo il codice java?? grazie in anticipo  ;-)

Offline vincenzoc

  • Utente junior
  • **
  • Post: 148
  • Respect: +47
    • Google+
    • cerminarav
    • Mostra profilo
    • Mie applicazioni sul Play Store
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Vincenzo Cerminara
  • Sistema operativo:
    Arch Linux
Re:navigation drawer per api 8
« Risposta #1 il: 27 Luglio 2013, 14:56:52 CEST »
0
Ciao darko,

Hai inserito la Suport Library nel tuo progetto? È essenziale per poter utilizzare il Navigation Drawer sulle versioni precedenti di Android. Come specificato nella guida da te postata, inoltre, la Support Library deve essere almeno alla versione 13.

Per aggiungere tale libreria al tuo progetto:
  • Click con il tasto destro sul tuo progetto in Eclipse
  • Android Tools
  • Add Support Library
Ringrazia chi ti aiuta sul forum con l'apposito pulsante :P
Scarica Yazzy