Autore Topic: Native Activity non funzionante su galaxy s4  (Letto 2395 volte)

Offline sams4

  • Nuovo arrivato
  • *
  • Post: 6
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows 8
Native Activity non funzionante su galaxy s4
« il: 10 Maggio 2013, 11:10:39 CEST »
0
Buongiorno a tutti.
Ho comprato un samsung galaxy s4, e subito dopo ho iniziato a utilizzarlo con Eclipse e OpenCV4Android (ver. 2.4.5) per cercare di sviluppare in ambiente Android. Dopo avere importato tutti i progetti di OpenCV in Eclipse, ho provato a farli girare sul mio telefono. Girano tutti correttamente, eccetto Native Activity, benchè sull'emulatore funzioni correttamente. 
Di seguito il logcat:

05-10 09:58:47.362: I/OCVSample::Activity(32253): OpenCV loaded successfully
05-10 09:58:47.362: D/dalvikvm(32253): Trying to load lib /data/app-lib/org.opencv.samples.NativeActivity-1/libnative_activity.so 0x420a7448
05-10 09:58:47.362: D/dalvikvm(32253): Added shared lib /data/app-lib/org.opencv.samples.NativeActivity-1/libnative_activity.so 0x420a7448
05-10 09:58:47.362: D/dalvikvm(32253): No JNI_OnLoad found in /data/app-lib/org.opencv.samples.NativeActivity-1/libnative_activity.so 0x420a7448, skipping init
05-10 09:58:47.512: I/OCV:libnative_activity(32253): APP_CMD_INIT_WINDOW
05-10 09:58:47.512: D/OpenCV::camera(32253): CvCapture_Android::CvCapture_Android(0)
05-10 09:58:47.512: D/OpenCV::camera(32253): Library name: libopencv_java.so
05-10 09:58:47.512: D/OpenCV::camera(32253): Library base address: 0x74079000
05-10 09:58:47.542: D/OpenCV::camera(32253): Libraries folder found: /data/app-lib/org.opencv.engine-1/
05-10 09:58:47.542: D/OpenCV::camera(32253): CameraWrapperConnector::connectToLib: folderPath=/data/app-lib/org.opencv.engine-1/
05-10 09:58:47.542: E/OpenCV::camera(32253): ||libnative_camera_r2.3.3.so
05-10 09:58:47.542: E/OpenCV::camera(32253): ||libnative_camera_r4.0.3.so
05-10 09:58:47.542: E/OpenCV::camera(32253): ||libnative_camera_r4.2.0.so
05-10 09:58:47.542: E/OpenCV::camera(32253): ||libnative_camera_r4.1.1.so
05-10 09:58:47.542: E/OpenCV::camera(32253): ||libnative_camera_r4.0.0.so
05-10 09:58:47.542: E/OpenCV::camera(32253): ||libnative_camera_r2.2.0.so
05-10 09:58:47.542: E/OpenCV::camera(32253): ||libnative_camera_r3.0.1.so
05-10 09:58:47.542: D/OpenCV::camera(32253): try to load library 'libnative_camera_r4.2.0.so'
05-10 09:58:47.552: D/OpenCV::camera(32253): Loaded library '/data/app-lib/org.opencv.engine-1/libnative_camera_r4.2.0.so'
05-10 09:58:47.552: D/OpenCV_NativeCamera(32253): CameraHandler::initCameraConnect(0x7440c191, 0, 0x70f32190, 0x0)
05-10 09:58:47.552: D/OpenCV_NativeCamera(32253): Connecting to CameraService v 3D
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Instantiated new CameraHandler (0x7440c191, 0x70f32190)
05-10 09:58:52.487: I/OpenCV_NativeCamera(32253): initCameraConnect: [ae-bracket-hdr=Off;ae-bracket-hdr-values=Off,HDR,AE-Bracket;anti-shake=0;antibanding=off;antibanding-values=off,50hz,60hz,auto;auto-exposure-lock=false;auto-exposure-lock-supported=true;auto-whitebalance-lock=false;auto-whitebalance-lock-supported=true;cam_mode=0;camera-mode=1;camera-mode-values=0,1;capture-burst-captures-values=2;capture-burst-exposures=;capture-burst-exposures-values=-12,-11,-10,-9,-8,-7,-6,-5,-4,-3,-2,-1,0,1,2,3,4,5,6,7,8,9,10,11,12;capture-burst-interval=1;capture-burst-interval-max=10;capture-burst-interval-min=1;capture-burst-interval-supported=true;capture-burst-retroactive=0;capture-burst-retroactive-max=2;contextualtag-cityid=0;contrast=5;denoise=denoise-off;denoise-values=denoise-off,denoise-on;display_mode=landscape;dual_mode=0;dualrecording-hint=-1;effect=none;effect-values=none,mono,negative,solarize,sepia,posterize,whiteboard,blackboard,aqua,emboss,sketch,neon,vintage-warm,vintage-cold,washed;exposure-compensation=0;exposure-compensation-step=1;face-detectio
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Cameras: (null)
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Picture Sizes: 4128x3096,4128x2322,3264x2448,3264x1836,2048x1536,2048x1152,1280x720,640x480
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Picture Formats: jpeg,raw
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Preview Sizes: 1920x1080,1440x1080,1280x720,1056x864,960x720,720x480,640x480,320x240,176x144
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Preview Formats: yuv420sp,yuv420sp-adreno,yuv420p,nv12
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Preview Frame Rates: 15,30
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Thumbnail Sizes: 512x288,480x288,432x288,512x384,352x288,320x240,176x144,0x0
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Whitebalance Modes: auto,incandescent,fluorescent,daylight,cloudy-daylight
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Effects: none,mono,negative,solarize,sepia,posterize,whiteboard,blackboard,aqua,emboss,sketch,neon,vintage-warm,vintage-cold,washed
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Scene Modes: auto,asd,action,portrait,landscape,night,night-portrait,theatre,beach,snow,sunset,steadyphoto,fireworks,sports,party,candlelight,back-light,flowers,AR,text,fall-color,dusk-dawn
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Focus Modes: auto,infinity,macro,continuous-picture,continuous-video
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Antibanding Options: off,50hz,60hz,auto
05-10 09:58:52.487: D/OpenCV_NativeCamera(32253): Supported Flash Modes: off,auto,on,torch
05-10 09:58:52.567: D/OpenCV_NativeCamera(32253): initCameraConnect: autofocus is set to mode "continuous-video"
05-10 09:58:52.577: D/OpenCV_NativeCamera(32253): initCameraConnect: preview format is set to yuv420sp
05-10 09:58:52.587: D/OpenCV_NativeCamera(32253): Starting preview
05-10 09:58:52.827: A/libc(32253): @@@ ABORTING: LIBC: HEAP MEMORY CORRUPTION IN tmalloc_small
05-10 09:58:52.827: A/libc(32253): Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1), thread 32279 (.NativeActivity)

Qualcuno è in grado di aiutarmi o di spiegarmi cosa è che non va?