Autore Topic: DEbug dal dispositivo  (Letto 884 volte)

Offline k3v1n

  • Utente junior
  • **
  • Post: 61
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung S3
DEbug dal dispositivo
« il: 20 Febbraio 2013, 21:32:16 CET »
0
Salve a tutti,

premetto che sono un neofita nello sviluppo android... sto sviluppando la mia prima app. Una semplice tabella che carica dei dati dal db sqlite. Dal simulatore tutto ok, ma quando carico l'apk sul device, l'app si apre ma non vedo nulla, titolo con pagina bianca, ma niente tabella.

Individuare il problema è dura. Avevo pensato di effettuare il debug da device come è possibile fare ad esempio mediante xcode per iphone. Ho attivato il debug usb sul device ma poi?

P.S. Io uso Mac con tool Eclipse Android Developer Tools - Build: v21.0.1-543035

Potreste darmi una mano?

Grazie

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3487
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:DEbug dal dispositivo
« Risposta #1 il: 20 Febbraio 2013, 22:11:07 CET »
0
- Metti i break point in Eclipse sulle istruzioni che vuoi analizzare
- Attacchi il telefono
- Da Eclipse fai: Run -> Debug


Offline giozh

  • Nuovo arrivato
  • *
  • Post: 5
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Galaxy Nexus
  • Sistema operativo:
    Kubuntu
Re:DEbug dal dispositivo
« Risposta #2 il: 21 Febbraio 2013, 17:39:11 CET »
0
Sicuro di non aver fatto confusione sul setContentView della main activity?

Offline k3v1n

  • Utente junior
  • **
  • Post: 61
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung S3
Re:DEbug dal dispositivo
« Risposta #3 il: 21 Febbraio 2013, 17:42:30 CET »
0
Sicuro di non aver fatto confusione sul setContentView della main activity?

stasera riprovo ma mi sembra strano... è un semplice activity con una tabella

super.onCreate(savedInstanceState);
setContentView(R.layout.my_layout);

Nulla di particolarmente complesso... ma al di la di tutto voglio capire come attivare il debug perchè mi è utile.

Grazie

Post unito: 21 Febbraio 2013, 19:12:23 CET
- Metti i break point in Eclipse sulle istruzioni che vuoi analizzare
- Attacchi il telefono
- Da Eclipse fai: Run -> Debug

perdonami ma non compare nessun dispositivo... devo aggiungerlo da qualche parte?


Post unito: 21 Febbraio 2013, 20:28:03 CET
Ho capito che il problema è l'accesso al db... sul simulatore funziona, sul dispositivo no... non riesco però a capire come accedere alla cartella data/data/... dal simulatore ok, ma dal device? come devo fare?

possibile sia il mac l'origine di questi miei problemi?
« Ultima modifica: 21 Febbraio 2013, 20:28:03 CET da luca.santaniello, Reason: Merged DoublePost »