Autore Topic: Minimum SDK  (Letto 1043 volte)

Offline smart

  • Nuovo arrivato
  • *
  • Post: 9
  • Respect: 0
    • Mostra profilo
Minimum SDK
« il: 09 Luglio 2012, 12:12:01 CEST »
0
Buongiorno,
sono completamente nuovo del mondo android, ho intenzione di sviluppare un'app per android e voglio che funzioni anche su dispositivi con FROYO e GINGERBREAD dato che la quota di mercato dei dispositivi con questa versione è ancora molto alta...
Ho installato SDK ed Eclipse ma a quanto ho capito posso sviluppare solo su Android 4.0.3.
Quando creo un progetto lascio come Build Target Android 4.0.3 ma come Minimum SDK ho solo 15. Come posso avere più opzioni come 8 (Android FROYO) nella combobox? Devo installare i vecchi sdk? Se si dove li posso trovare perchè nell' SDK manager non ci sono...

Grazie!
Ciao!
« Ultima modifica: 09 Luglio 2012, 12:18:45 CEST da smart »

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Minimum SDK
« Risposta #1 il: 09 Luglio 2012, 12:30:34 CEST »
0
Come hai giustamente intuito, l'ideale è mettere TARGET_SDK a 15 (o 16 jelly bean), e MIN_SDK a 8 (Froyo).

Se non ti fa mettere il minimum a 8 vuol dire che hai selezionato qualche feature che impone 15 come minimo oppure manca qualcosa.

Non credo dipenda dai vecchi SDK, che comunque sono tutti nell'SDK manager (almeno nel mio ci sono).
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline smart

  • Nuovo arrivato
  • *
  • Post: 9
  • Respect: 0
    • Mostra profilo
Re:Minimum SDK
« Risposta #2 il: 09 Luglio 2012, 13:59:30 CEST »
0
Ciao,
ho fatto uno screeshot su come creo un progetto in eclipse http://i47.tinypic.com/1zefes9.png, come puoi vedere come Minimum SDK ho solo 4.0.3.
Mentre qui puoi vedere SDK Manager http://i49.tinypic.com/1zf2801.png , tu ha altri packages oltra ad Android 4.0.3?

Ciao!
« Ultima modifica: 09 Luglio 2012, 14:02:53 CEST da smart »

Offline eagledeveloper

  • Translate Team
  • Utente senior
  • ****
  • Post: 516
  • Respect: +37
    • Google+
    • 347516210
    • dark_pinz
    • @WandDStudios
    • Mostra profilo
    • W&D Studios
  • Dispositivo Android:
    HTC One X e HTC One
  • Play Store ID:
    W%26D+Studios
  • Sistema operativo:
    Ubuntu / Windows 7
Re:Minimum SDK
« Risposta #3 il: 09 Luglio 2012, 14:13:47 CEST »
0
Devi installarti anche le altre API (8, 10 e 13).
I numeri contano molto di più del seme.

Offline smart

  • Nuovo arrivato
  • *
  • Post: 9
  • Respect: 0
    • Mostra profilo
Re:Minimum SDK
« Risposta #4 il: 09 Luglio 2012, 15:23:30 CEST »
0
Devi installarti anche le altre API (8, 10 e 13).

Perfetto ho installato tutto! Ora funziona!
Grazie a tutti!

Offline eagledeveloper

  • Translate Team
  • Utente senior
  • ****
  • Post: 516
  • Respect: +37
    • Google+
    • 347516210
    • dark_pinz
    • @WandDStudios
    • Mostra profilo
    • W&D Studios
  • Dispositivo Android:
    HTC One X e HTC One
  • Play Store ID:
    W%26D+Studios
  • Sistema operativo:
    Ubuntu / Windows 7
Re:Minimum SDK
« Risposta #5 il: 09 Luglio 2012, 15:37:48 CEST »
0
Prego, se hai bisogno chiedi pure.
I numeri contano molto di più del seme.