Autore Topic: "import" non importa..help!!  (Letto 767 volte)

Offline Sebastian

  • Utente junior
  • **
  • Post: 81
  • Respect: 0
    • Mostra profilo
"import" non importa..help!!
« il: 12 Agosto 2010, 12:57:51 CEST »
0
Salve a tutti,
programmando un applicazione android in eclipse se scrivo:

-"import android.content.IntentReceiver;"
il programma mi dice: "The import android.content.IntentReceiver cannot be resolved"

mentre se scrivo:
-"import android.telephony.gsm.SmsMessage;"
il programma mi dice: "The type SmsMessage is deprecated"

e lo fa anche con altri import... sapete per caso che significa e come si può rimediare?

Mille grazie

Offline Qlimax

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 757
  • Respect: +202
    • Google+
    • _Qlimax
    • Mostra profilo
    • www.egsolutions.ch
  • Dispositivo Android:
    Galaxy Nexus - Nexus One - Wildfire - Magic
  • Play Store ID:
    egsolutions.ch
  • Sistema operativo:
    Ubuntu 12.04, Windows 7
Re:"import" non importa..help!!
« Risposta #1 il: 12 Agosto 2010, 14:24:34 CEST »
0
Search Results | Android Developers

IntentReceiver non è nelle API di android... forse quello che ti serve è BroadcastReceiver BroadcastReceiver | Android Developers


android.telephony.gsm.SmsMessage è deprecata (http://it.wiktionary.org/wiki/deprecato):
SmsMessage | Android Developers

il consiglio è di usare questa classe (che supporta sia gsm che cdma)
SmsMessage | Android Developers

;)

Offline Sebastian

  • Utente junior
  • **
  • Post: 81
  • Respect: 0
    • Mostra profilo
Re:"import" non importa..help!!
« Risposta #2 il: 12 Agosto 2010, 14:34:14 CEST »
0
ma allora, siccome mi dice la stessa cosa di intentreceiver anche quando vado ad importare le classi per usare le google Map (le più comuni), come faccio ad importare le API che non sono di android?
 pensi debba usare per l'emulatore quello Google8?

Mille grazie!!!! ;-)

Offline Qlimax

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 757
  • Respect: +202
    • Google+
    • _Qlimax
    • Mostra profilo
    • www.egsolutions.ch
  • Dispositivo Android:
    Galaxy Nexus - Nexus One - Wildfire - Magic
  • Play Store ID:
    egsolutions.ch
  • Sistema operativo:
    Ubuntu 12.04, Windows 7
Re:"import" non importa..help!!
« Risposta #3 il: 12 Agosto 2010, 14:45:20 CEST »
+1
per usare le classi di Google Maps devi usare le  "Google APIs", quindi in [Proprietà del progetto->Android]  spunta "Google Apis" invece di, ad esempio, "Android 1.6"

poi, per far funzionare il codice, anche l'emulatore dev'essere creato come "Google Apis"

Offline Sebastian

  • Utente junior
  • **
  • Post: 81
  • Respect: 0
    • Mostra profilo
Re:"import" non importa..help!!
« Risposta #4 il: 12 Agosto 2010, 19:28:32 CEST »
0
Grazia mille!! pollice in suuuuuuuuuu!
adesso il programma per le googlemap gira   :-)..(mentre per far funzionare quello sugli SMS devo cambiare classi da quanto ho capito, vero?)

Senza aprire un nuovo thread posso chiederti un altra cosa semplice (per te ovviamente, non per me.. :-P)?
Parlando sempre del programma con le googlemap, dopo che lo lancio mi dice:  "the application has stopped unexpectedly" allora ho provato ad usare l' adb ma sembra che nel mio android sdk  ci sia solo l'icona adb ma non il programma.. hai per caso qualche idea su come  posso rimediare?



Offline Qlimax

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 757
  • Respect: +202
    • Google+
    • _Qlimax
    • Mostra profilo
    • www.egsolutions.ch
  • Dispositivo Android:
    Galaxy Nexus - Nexus One - Wildfire - Magic
  • Play Store ID:
    egsolutions.ch
  • Sistema operativo:
    Ubuntu 12.04, Windows 7
Re:"import" non importa..help!!
« Risposta #5 il: 12 Agosto 2010, 19:50:17 CEST »
0
in eclipse, per visualizzare il Logcat (dove puoi capire le cause di un errore), fai cosi:

Window->Show View->Other...->Android->Logcat

e sotto il riquadro dove scrivi il codice, apparirà una tab di logcat :) in rosso vedi quando  il programma genera delle eccezioni, e quindi crasha.
« Ultima modifica: 12 Agosto 2010, 19:55:05 CEST da Qlimax »

Offline Sebastian

  • Utente junior
  • **
  • Post: 81
  • Respect: 0
    • Mostra profilo
Re:"import" non importa..help!!
« Risposta #6 il: 12 Agosto 2010, 22:56:38 CEST »
0
Mille grazie!