Autore Topic: problema Style  (Letto 934 volte)

Offline Luigi.Arena

  • Utente senior
  • ****
  • Post: 616
  • DACIA DUSTER 4X4 SUPER
  • Respect: +56
    • Mostra profilo
    • ArenaWebTest
  • Dispositivo Android:
    epad m009
  • Play Store ID:
    Luigi Arena
  • Sistema operativo:
    Windows 7
problema Style
« il: 18 Luglio 2011, 15:40:41 CEST »
0
Ciao,
ho questo style:
Codice (XML): [Seleziona]
<style name="textviwestyle01">
        <item name="android:textStyle">bold|italic</item>
        <item name="android:textColor">#FFFFFF</item>
        <item name="android:textSize">30sp</item>
        <item name="android:typeface">monospace</item>
        <item name="android:padding">10dp</item>
        <item name="android:layout_weight">1</item>
        <item name="android:layout_gravity">left</item>
         </style>  

lo applico ad una textview ma nella grafica non vedo nulla.

Questa è l'associazione dello style alla textview:
Codice: [Seleziona]
<TextView android:text="Ripeti:" android:id="@+id/lblripeti"
  style="@style/textviwestyle01">
</TextView>
Grazie
È stata trovata una soluzione al tuo problema?Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato .

Offline Nicola_D

  • Moderatore
  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:problema Style
« Risposta #1 il: 18 Luglio 2011, 15:43:54 CEST »
0
Ciao,
ho questo style:
Codice (XML): [Seleziona]
<style name="textviwestyle01">
        <item name="android:textStyle">bold|italic</item>
        <item name="android:textColor">#FFFFFF</item>
        <item name="android:textSize">30sp</item>
        <item name="android:typeface">monospace</item>
        <item name="android:padding">10dp</item>
        <item name="android:layout_weight">1</item>
        <item name="android:layout_gravity">left</item>
         </style>  

lo applico ad una textview ma nella grafica non vedo nulla.

Questa è l'associazione dello style alla textview:
Codice: [Seleziona]
<TextView android:text="Ripeti:" android:id="@+id/lblripeti"
  style="@style/textviwestyle01">
</TextView>
Grazie

hai dimenticato il layout_height e layout_width
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia

Offline Luigi.Arena

  • Utente senior
  • ****
  • Post: 616
  • DACIA DUSTER 4X4 SUPER
  • Respect: +56
    • Mostra profilo
    • ArenaWebTest
  • Dispositivo Android:
    epad m009
  • Play Store ID:
    Luigi Arena
  • Sistema operativo:
    Windows 7
Re:problema Style
« Risposta #2 il: 18 Luglio 2011, 16:00:28 CEST »
0
Grazie!
Avevo già provato ma non va, non riesco a capire cosa non gli piace.
È stata trovata una soluzione al tuo problema?Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato .

Offline Nicola_D

  • Moderatore
  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:problema Style
« Risposta #3 il: 18 Luglio 2011, 16:05:50 CEST »
+1
togli bold oppure italic.
mi pare che le tv non accettano entrambi. Fai una prova
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia

Offline Luigi.Arena

  • Utente senior
  • ****
  • Post: 616
  • DACIA DUSTER 4X4 SUPER
  • Respect: +56
    • Mostra profilo
    • ArenaWebTest
  • Dispositivo Android:
    epad m009
  • Play Store ID:
    Luigi Arena
  • Sistema operativo:
    Windows 7
Re:problema Style
« Risposta #4 il: 18 Luglio 2011, 16:39:22 CEST »
0
Grazie Nicola.
Quello che crea problemi è "Italic", anche da solo.
È stata trovata una soluzione al tuo problema?Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato .

Offline Nicola_D

  • Moderatore
  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:problema Style
« Risposta #5 il: 18 Luglio 2011, 16:45:08 CEST »
0
Grazie Nicola.
Quello che crea problemi è "Italic", anche da solo.
strano, da solo ero riuscito ad applicarlo alla tv... non riuscivo a fare il bolditalic, solo con le edittext...
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia

Offline Luigi.Arena

  • Utente senior
  • ****
  • Post: 616
  • DACIA DUSTER 4X4 SUPER
  • Respect: +56
    • Mostra profilo
    • ArenaWebTest
  • Dispositivo Android:
    epad m009
  • Play Store ID:
    Luigi Arena
  • Sistema operativo:
    Windows 7
Re:problema Style
« Risposta #6 il: 18 Luglio 2011, 17:21:07 CEST »
0
Ti confermo che se setto  in una textview la proprietà textstyle=italic la textview sparisce.

Però Nicola, io ricordo che lo style che ho postato l'avevo utilizzato e funzionava  :-(
con BOLD|ITALIC.
Per altro il sorgente l'avevo preso dalla rivista IOProgrammo.
Comunque Grazie
È stata trovata una soluzione al tuo problema?Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato .

Offline Luigi.Arena

  • Utente senior
  • ****
  • Post: 616
  • DACIA DUSTER 4X4 SUPER
  • Respect: +56
    • Mostra profilo
    • ArenaWebTest
  • Dispositivo Android:
    epad m009
  • Play Store ID:
    Luigi Arena
  • Sistema operativo:
    Windows 7
Re:problema Style
« Risposta #7 il: 18 Luglio 2011, 17:27:28 CEST »
0
Ora ricordo!!!! :-o

In esecuzione non da problemi e funziona, ma in design crea problemi.
Bene. ;-)
È stata trovata una soluzione al tuo problema?Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato .