Autore Topic: facebook e single sign on  (Letto 658 volte)

Offline Tk.3

  • Nuovo arrivato
  • *
  • Post: 41
  • Respect: +2
    • Mostra profilo
  • Sistema operativo:
    Windows 7
facebook e single sign on
« il: 30 Maggio 2011, 11:27:43 CEST »
0
Salve ragazzi, ho un piccolo problema che proprio non riesco a risolvere:
sto creando nella mia app un login tramite facebook.
per farlo mi sono basato sullo snippet Facebook e Single Sign On, non vi disperate! - Android Developers Italia

premetto che lavoro su windows 7.
Il problema è che quando vado ad eseguire
Codice (Java): [Seleziona]
keytool -exportcert -alias androiddebugkey -keystore debug.keystore | openssl sha1 -binary| openssl base64
da cygwin (che ho precedentemente installato) mi viene ritornata la risposta: "Keytool: Command not found".
Le ho provate tutte, ho addirittura provato ad installare cygwin con TUTTI i suoi elementi (superando i 3,50 giga) ma
keytool è sempre un problema.

Qualcuno ha idea di come posso risolvere?

Sò che può sembrare una stupidaggine, ma sto lavorando così tanto in questi giorni che il mio cervello è ormai in pappa e mi
sto perdendo in un bicchier d'acqua....

Offline Nicola_D

  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
R: facebook e single sign on
« Risposta #1 il: 30 Maggio 2011, 12:20:28 CEST »
+1
Hai verificato di avere la cartella bin di Java nel path di sistema? Keytool è un file exe di java!!

Inviato dal mio Nexus S usando Tapatalk
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia

Offline Tk.3

  • Nuovo arrivato
  • *
  • Post: 41
  • Respect: +2
    • Mostra profilo
  • Sistema operativo:
    Windows 7
Re:facebook e single sign on
« Risposta #2 il: 30 Maggio 2011, 12:26:28 CEST »
0
devo avere cygwin e Java installate entrambe in C:/, giusto?

Offline Tk.3

  • Nuovo arrivato
  • *
  • Post: 41
  • Respect: +2
    • Mostra profilo
  • Sistema operativo:
    Windows 7
Re:facebook e single sign on
« Risposta #3 il: 30 Maggio 2011, 12:52:26 CEST »
0
problema 1 risolto. Ho impostato tutto correttamente.
Ora il problema è OpenSSL.  >:(

Offline Nicola_D

  • Utente storico
  • *****
  • Post: 2479
  • SBAGLIATO!
  • Respect: +323
    • Github
    • Google+
    • nicoladorigatti
    • Mostra profilo
  • Dispositivo Android:
    Nexus 6p, Nexus 4, Nexus S, Nexus 7(2012)
  • Sistema operativo:
    Windows 7
Re:facebook e single sign on
« Risposta #4 il: 30 Maggio 2011, 13:06:55 CEST »
0
problema 1 risolto. Ho impostato tutto correttamente.
Ora il problema è OpenSSL.  >:(
che problema hai con openssl?
IMPORTANTE:NON RISPONDO A PROBLEMI VIA MESSAGGIO PRIVATO
LOGCAT: Non sai cos'è? -> Android Debug Bridge | Android Developers
               Dov'è in Eclipse? -> Window -> Open Prospective -> DDMS e guarda in basso!
[Obbligatorio] Logcat, questo sconosciuto! (Gruppo AndDev.it LOGTFO) - Android Developers Italia

Offline Tk.3

  • Nuovo arrivato
  • *
  • Post: 41
  • Respect: +2
    • Mostra profilo
  • Sistema operativo:
    Windows 7
Re:facebook e single sign on
« Risposta #5 il: 30 Maggio 2011, 13:09:41 CEST »
0
l'ho installato in precedenza, ma mi da un errore strano. Provo a reinstallare il tutto, forse lo sclero di questi giorni mi ha portato
a creare un casino sul cygwin al punto tale da averlo imputtanato...

Offline Tk.3

  • Nuovo arrivato
  • *
  • Post: 41
  • Respect: +2
    • Mostra profilo
  • Sistema operativo:
    Windows 7
Re:facebook e single sign on
« Risposta #6 il: 30 Maggio 2011, 13:23:40 CEST »
0
come pensavo, avevo impallato il Cygwin (non chiedermi come).
Ho reinstallato tutto, come specificato nella guida e funziona perfettamente.
Codice ottenuto ;) Grazie 1000.


Topic Risolto!

Offline Tk.3

  • Nuovo arrivato
  • *
  • Post: 41
  • Respect: +2
    • Mostra profilo
  • Sistema operativo:
    Windows 7
Re:facebook e single sign on
« Risposta #7 il: 30 Maggio 2011, 13:29:11 CEST »
0
Approfitto per dire un'altra cosa, qualora qualcuno abbia delle difficoltà simili a quelle che ho incontrato io.

Se il comando Keytool vi da problemi e siete sicuri di aver installato Java, il problema può essere solo uno:
non avete impostato la variabile d'ambiente.
Per farlo, se vi trovate su Windows, seguite questo link: http://www.dis.uniroma1.it/~figest/install.html
molto chiaro e preciso.
Se il problema è invece l'openssl, rilanciate il setup del programma, scrivete nella barra di ricerca, in fase di
installazione, "openssl" ed installate tutti i pacchetti che vi verranno mostrati.
Questi sono gli errori che io ho riscontrato e che ho così risolto...