Autore Topic: L'emulatore non si spegne  (Letto 1361 volte)

Offline vincenzo_a

  • Nuovo arrivato
  • *
  • Post: 3
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows 7 64bit
L'emulatore non si spegne
« il: 17 Febbraio 2011, 12:27:57 CET »
0
Un saluto a tutti! Questo è il mio primo topic in questo forum.

Ho installato su una vm con winxp l'ambiente di sviluppo per Android (sdk, emulatore ed eclipse) e sembrava funzionare tutto
Purtroppo quando tento di spegnere la virtual device che ho creato (Platform 2.2, API leve 8) questa rimane in spegnimento in corso per un tempo indefinito!
Dopo qualche minuto provo a chiudere la finestra dell'emulatore emi blocca il processo.
Da taskmanger non permettere di chiusere il processo e sono costretto a riavviare la vm.

Qualcuna sa darmi un consiglio?
Grazie

Offline blackgin

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 1387
  • Respect: +164
    • Google+
    • blackgins
    • blackginsoft
    • Mostra profilo
  • Dispositivo Android:
    Galaxy Nexus
  • Sistema operativo:
    Mac OSX 10.8
Re:L'emulatore non si spegne
« Risposta #1 il: 21 Febbraio 2011, 14:33:41 CET »
0
Io ho sempre chiuso premendo il pulsante chiudi della finestra emulatore. Credo sia normale.
Postate il LogCat LogCat LogCat LogCat LogCat

Offline vincenzo_a

  • Nuovo arrivato
  • *
  • Post: 3
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows 7 64bit
Re:L'emulatore non si spegne
« Risposta #2 il: 21 Febbraio 2011, 16:56:49 CET »
0
Ti rigrazio per la risposta.

Ma quando io chiudo la finestra mi si blocca il processo (l'emulatore non reagisce più)
non riesco a chiudere il processo neanche dal taskmanger
sono costretto a riavviare la vm.

Penso ci sia qualcosa di danneggiato a livello s.o., penso proprio che reinstallerò tutto.

Offline sora101

  • Nuovo arrivato
  • *
  • Post: 21
  • Respect: +2
    • Mostra profilo
Re:L'emulatore non si spegne
« Risposta #3 il: 21 Febbraio 2011, 17:11:19 CET »
0
posso chiederti perchè usi una vm con winxp? e inoltre che errore ti da il task manager?

Offline vincenzo_a

  • Nuovo arrivato
  • *
  • Post: 3
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows 7 64bit
Re:L'emulatore non si spegne
« Risposta #4 il: 21 Febbraio 2011, 17:19:42 CET »
0
Io normalmente sviluppo in ambiente visual studio.
Volendo sviluppare in Android ho preferito iniziare creandomi un ambiente di sviluppo in una vm (appunto con winxp).
Così da sperimentare un po.

Comunque il taskmanager non mi da nessun errore, semplicemente non mi chiude il task.

Offline sora101

  • Nuovo arrivato
  • *
  • Post: 21
  • Respect: +2
    • Mostra profilo
Re:L'emulatore non si spegne
« Risposta #5 il: 21 Febbraio 2011, 21:04:32 CET »
0
Anch'io uso visual studio per motivi di lavoro ma ti assicuro che eclipse con l'sdk di google è 100% compatibile anche perchè volendo si potrebbe rendere tutto TOTALMENTE portatile quindi addirittura da chiavetta senza lasciare tracce!
Comunque se proprio vuoi usare la vm... quanta ram/spazio ti prende? L'emulatore in genere succhia tantissimo! tant'è che va già lento di suo..su una vm non so come potrebbe reagire..

Offline blackgin

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 1387
  • Respect: +164
    • Google+
    • blackgins
    • blackginsoft
    • Mostra profilo
  • Dispositivo Android:
    Galaxy Nexus
  • Sistema operativo:
    Mac OSX 10.8
Re:L'emulatore non si spegne
« Risposta #6 il: 21 Febbraio 2011, 21:48:58 CET »
0
Io ancora non ho capito perché usi una vm o.O
Postate il LogCat LogCat LogCat LogCat LogCat

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3487
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:L'emulatore non si spegne
« Risposta #7 il: 21 Febbraio 2011, 21:55:24 CET »
0
Io ancora non ho capito perché usi una vm o.O

Perchè magari non vuole "sporcare l'os". Non è proprio una brutta idea. ;)

Offline JD

  • Amministratore
  • Utente storico
  • *****
  • Post: 1600
  • Respect: +232
    • leinardi
    • Mostra profilo
  • Dispositivo Android:
    LG Nexus 5
  • Sistema operativo:
    L'ultima Ubuntu
Re:L'emulatore non si spegne
« Risposta #8 il: 23 Febbraio 2011, 04:46:37 CET »
0
Perchè magari non vuole "sporcare l'os". Non è proprio una brutta idea. ;)
Windows... XD
È stata trovata una soluzione al tuo problema?
Evidenzia il post più utile premendo . È un ottimo modo per ringraziare chi ti ha aiutato ;).
E se hai aperto tu il thread marcalo come risolto cliccando !

Offline stepava

  • Nuovo arrivato
  • *
  • Post: 28
  • Respect: +1
    • Google+
    • StePava
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy Nexus & T-Mobile G1
  • Play Store ID:
    StePped Apps
  • Sistema operativo:
    Linux - Ubuntu 11.10
Re:L'emulatore non si spegne
« Risposta #9 il: 26 Giugno 2011, 10:38:33 CEST »
0
Ciao a tutti, anche io ho lo stesso problema...
Uso Eclipse (Helios) sotto Linux 64Bit (Provato sia su Ubuntu che ora su Mint).. pero' il problema non mi si era mai presentato, ho sempre chiuso l'emulatore con il tasto chiudi.
Ho cominciato ad avere questo problema dall'ultimo aggiornamento dell'ADT (11 credo).
ho notato che è stata aggiunta l'opzione di save snapshot e launch from snapshot.. ad avviarsi è una scheggia perchè parte dall'ultima "ibernazione".... ma non si chiude... devo "killarlo" con xkill altimenti non c'è verso... cosa potrebbe essere?

Offline stepava

  • Nuovo arrivato
  • *
  • Post: 28
  • Respect: +1
    • Google+
    • StePava
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy Nexus & T-Mobile G1
  • Play Store ID:
    StePped Apps
  • Sistema operativo:
    Linux - Ubuntu 11.10
Re:L'emulatore non si spegne
« Risposta #10 il: 26 Giugno 2011, 10:45:14 CEST »
0
Posso dare un suggerimento, ho provato a creare un altro emulatore... senza abilitare gli "snapshot" e funziona a meraviglia.... (ci mette una vita ad avviarsi perchè fa il boot completo), ma si chiude senza problemi...
Bisognerebbe capire perchè gli snapshot creano questo problema, pero' è "colpa" di questa funziona se l'emulatore non si chiude...