Autore Topic: Grandle sync project failed ver.2.2.2  (Letto 217 volte)

Offline ssormanni

  • Nuovo arrivato
  • *
  • Post: 4
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    samsung S4
  • Sistema operativo:
    linux mint
Grandle sync project failed ver.2.2.2
« il: 20 Novembre 2016, 16:09:16 CET »
0
Salve a tutti,
ho installato la versione 2.2.2 di android studio e subito dopo aver creato un progetto ha visto che ho questo tipo di errore: Error:Process 'command '/home/stefano/android-studio/jre/bin/java'' finished with non-zero exit value 2 penso sia un problema delle proprietà di Grandle, che sono qua sotto:
#Mon Dec 28 10:00:20 PST 2015
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip


Il log mi dice questo: org.gradle.tooling.GradleConnectionException: Could not run build action using Gradle installation '/home/stefano/android-studio/gradle/gradle-2.14.1'.
sulla finestra comandi appare: [  62751]   WARN - roid.tools.ndk.GradleWorkspace - NDK support for project 'MioProgetto' is disabled because the project doesn't contain any valid native configurations.

Utilizzo Linux Mint 18 con  versione java è la 1.8.0_111

qualcuno sa cosa devo controllare o modificare ?

Grazie, Stefano
« Ultima modifica: 20 Novembre 2016, 16:52:32 CET da ssormanni »

Offline iClaude

  • Utente normale
  • ***
  • Post: 177
  • Respect: +11
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy S5
  • Sistema operativo:
    Windows 10
Re:Grandle sync project failed ver.2.2.2
« Risposta #1 il: 21 Novembre 2016, 09:41:56 CET »
0
Prova ad aggiornare la versione di Gradle (l'ultima dovrebbe essere la 3.1 - verifica sul sito di Gradle).

a) File - Settings - Build - Gradle: impostare "use default Gradle wrapper"
b) modifica la linea distributionUrl del file gradle-wrapper.properties mettendo l'ultima versione
c) sync
d) (eventuale) File - invalidate caches and restart

Offline ssormanni

  • Nuovo arrivato
  • *
  • Post: 4
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    samsung S4
  • Sistema operativo:
    linux mint
Re:Grandle sync project failed ver.2.2.2
« Risposta #2 il: 21 Novembre 2016, 18:47:22 CET »
0
ciao iClaude,
ho fatto ciò che mi hai scritto, ma sfortunatamente non ho ottenuto risultati: ho sempre Error:Process 'command '/home/stefano/android-studio/jre/bin/java'' finished with non-zero exit value 2
dato che il mio PC è 32bit potrebbe essere quello il problema?


Offline iClaude

  • Utente normale
  • ***
  • Post: 177
  • Respect: +11
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy S5
  • Sistema operativo:
    Windows 10
Re:Grandle sync project failed ver.2.2.2
« Risposta #3 il: 22 Novembre 2016, 08:43:03 CET »
0
Posta il contenuto del file gradle (modulo app).

Offline ssormanni

  • Nuovo arrivato
  • *
  • Post: 4
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    samsung S4
  • Sistema operativo:
    linux mint
Re:Grandle sync project failed ver.2.2.2
« Risposta #4 il: 22 Novembre 2016, 22:44:24 CET »
0
Ciao iClaude,
ho allegato la schermata del modulo app

ciao e grazie
« Ultima modifica: 22 Novembre 2016, 22:49:27 CET da ssormanni »

Offline iClaude

  • Utente normale
  • ***
  • Post: 177
  • Respect: +11
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy S5
  • Sistema operativo:
    Windows 10
Re:Grandle sync project failed ver.2.2.2
« Risposta #5 il: 23 Novembre 2016, 12:10:34 CET »
0
Nella directory libs hai per caso inserito delle librerie jar?
Cmq prova anche a lanciare clean.

Offline ssormanni

  • Nuovo arrivato
  • *
  • Post: 4
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    samsung S4
  • Sistema operativo:
    linux mint
Re:Grandle sync project failed ver.2.2.2
« Risposta #6 il: 23 Novembre 2016, 21:14:06 CET »
0
Nella Directory Libs non ho nulla. Ho disinstallato e reinstallato android-studio ma l'errore di sync Gradle ricompare; ciò significa che non era un errore di installzione :-(
« Ultima modifica: 23 Novembre 2016, 21:58:37 CET da ssormanni »