Autore Topic: Problema Su Servizio ASUS ZenPhone 2  (Letto 98 volte)

Offline Robustelli

  • Nuovo arrivato
  • *
  • Post: 3
  • Respect: +1
    • Mostra profilo
  • Dispositivo Android:
    Asus ZenPhone2
  • Sistema operativo:
    Andorid 5.0
Problema Su Servizio ASUS ZenPhone 2
« il: 20 Ottobre 2016, 17:24:35 CEST »
+1
Salve a tutti,
sono nuovo nel mondo android

sto' progettando un app che per quanto è semplice mi stà facendo
impazzire.. o meglio , ero convto che sbagliassi qualcosa fino a quando
non l' ho testata su altro dispositivo e magia... tutto funzionava...

vi spiego in breve

l'app fa una query su un DB, se il risultato è maggiore di una costante X
mi avverte tramite Notifica... quando effettuo i test su Samsung e Nexus
il servizio parte al boot ... apro l'app ... la chiudo... la riapro e il servizio
è sempre li che notifica

Quando la testo su dispositivi ASUS ... il servizio non parte al boot
apro l'app.. il servizio si apre... chiudo l'app... il servizio non viene distrutto
(ho messo un toast che non mi viene generato) ... ma le notifiche non arrivano più
come se il servizio non fosse in funzione ... infatti quando riapro l' app
il servizio viene Avviato cosa che non farebbe se fosse già avviato

vi è mai successa una cosa del genere.. avete qualche idea

un ringraziamento in anticipo per tutti coloro che vorranno cimentarsi in una risposta.

Post unito: 21 Ottobre 2016, 09:44:41 CEST
Fatti una Domanda... e datti una risposta

per tutti coloro che hanno / avranno lo stesso problema

dopo 15 giorni di scambio Mail con Asus
e continui "E' Colpa Tua"
scopro che sui cellulari/tablet Asus gira un' applicazione
chiamata  auto-start manager questa applicazione segnalava la
mia come "SerieB" quindi inibendo l' Autostart .... abilitandola
funziona tutto perfettamente !

grazie comunque per l' attenzione
« Ultima modifica: 21 Ottobre 2016, 09:44:41 CEST da Robustelli, Reason: Merged DoublePost »