Autore Topic: Problema actionbarcompat  (Letto 403 volte)

Offline mikmontana

  • Nuovo arrivato
  • *
  • Post: 9
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Nexus 7
  • Sistema operativo:
    Ubuntu 12.04, Windows 7
Problema actionbarcompat
« il: 15 Giugno 2014, 16:38:22 CEST »
0
Ciao,
ho provato ad includere actionbarcompat alla mia applicazione per poterla rendere compatibile con le vecchie versioni di android, ma quando la installo su un android froyo mi dice che si è verificato un errore e chiude l'applicazione. Non dovrebbe funzionare anche su questa versione di android??

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Problema actionbarcompat
« Risposta #1 il: 15 Giugno 2014, 17:40:36 CEST »
0
Hai impostato un MINSDK adeguato nel manifest?
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline mikmontana

  • Nuovo arrivato
  • *
  • Post: 9
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Nexus 7
  • Sistema operativo:
    Ubuntu 12.04, Windows 7
Re:Problema actionbarcompat
« Risposta #2 il: 16 Giugno 2014, 10:59:31 CEST »
0
Si si:
Codice (XML): [Seleziona]
    <uses-sdk
       android:minSdkVersion="7"
       android:targetSdkVersion="17" />


Offline GabMarioPower

  • Moderatore globale
  • Utente senior
  • *****
  • Post: 606
  • Respect: +152
    • Github
    • Google+
    • gabrielemariotti
    • GabMarioPower
    • Mostra profilo
  • Play Store ID:
    GAB+MARIO+DEV
  • Sistema operativo:
    Ubuntu 14.04 , Win 10
Re:Problema actionbarcompat
« Risposta #3 il: 16 Giugno 2014, 23:27:39 CEST »
0
Ciao,
ho provato ad includere actionbarcompat alla mia applicazione per poterla rendere compatibile con le vecchie versioni di android, ma quando la installo su un android froyo mi dice che si è verificato un errore e chiude l'applicazione. Non dovrebbe funzionare anche su questa versione di android??

LOGCAT please!

Si si:
Codice (XML): [Seleziona]
    <uses-sdk
       android:minSdkVersion="7"
       android:targetSdkVersion="17" />

C'è un motivo per arrivare a supportare il 7? Non basta l'8? (alcune api sono minsdk=8).
Dispositivi con api7 non ce ne sono piu.
https://developer.android.com/about/dashboards/index.html?utm_source=ausdroid.net
« Ultima modifica: 16 Giugno 2014, 23:29:17 CEST da GabMarioPower »

Offline mikmontana

  • Nuovo arrivato
  • *
  • Post: 9
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Nexus 7
  • Sistema operativo:
    Ubuntu 12.04, Windows 7
Re:Problema actionbarcompat
« Risposta #4 il: 09 Agosto 2014, 12:03:10 CEST »
0
Ciao, ho modificato la minsdk=8, ma continua a non funzionare su un android 2.2.1. Riesco a installarlo correttamente, ma quando cerco di aprire l'app mi esce il seguente mesasggio: "Siamo spiacenti! L'applicazione si è arrestata improvvisamente. Riprovare."
« Ultima modifica: 09 Agosto 2014, 12:07:07 CEST da mikmontana »

Offline Rino63

  • Utente normale
  • ***
  • Post: 161
  • Respect: +3
    • Mostra profilo
Re:Problema actionbarcompat
« Risposta #5 il: 09 Agosto 2014, 12:25:43 CEST »
0
io partirei da minsdk=9 così sei compatibile con il nuovo google play sdk per gli aggiornamenti