Autore Topic: problema nell\' avvio di activity secondaria  (Letto 215 volte)

Offline Andre99

  • Utente junior
  • **
  • Post: 54
  • Respect: +1
    • Mostra profilo
  • Dispositivo Android:
    Vodafone 875
  • Play Store ID:
    F. Andreuzzi
  • Sistema operativo:
    Linux Mint 16 Cinnamon
problema nell\' avvio di activity secondaria
« il: 03 Maggio 2014, 15:41:35 CEST »
0
ciao, ho un problema con lo sviluppo di un app semplice (una calcolatrice). quando avvio l activity secondaria con startActivityForResult, pur avendo registrato ogni activity nel manifest, quando clicco sul bottone ch dovrebbe avviare l activity non cambia la schermata. quale puo essere il problema?

Post unito: 03 Maggio 2014, 15:43:23 CEST
ciao, scusate sono scemo, non avevo assegnato il listener al bottone  :-P
« Ultima modifica: 03 Maggio 2014, 15:43:23 CEST da Andre99, Reason: Merged DoublePost »
Andre99
Trieste-12/12/1999
T-UI, Terminal Console Launcher: https://play.google.com/store/apps/details?id=ohi.andre.consolelauncher

Offline Trotto23

  • Utente junior
  • **
  • Post: 94
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows Vista
Re:problema nell' avvio di activity secondaria
« Risposta #1 il: 03 Maggio 2014, 15:45:04 CEST »
0
sicuro che quando fai: Intent intent = new intent ( this , NomeDellaSecondaActivity.class )
dove ci va Nomedellasecondaactivity.class metti il nome giusto?

oppure successivamente fai ; startActivity(intent) ?

Offline Andre99

  • Utente junior
  • **
  • Post: 54
  • Respect: +1
    • Mostra profilo
  • Dispositivo Android:
    Vodafone 875
  • Play Store ID:
    F. Andreuzzi
  • Sistema operativo:
    Linux Mint 16 Cinnamon
Re:problema nell\' avvio di activity secondaria
« Risposta #2 il: 03 Maggio 2014, 16:39:25 CEST »
0
Grazie ho risolto
Andre99
Trieste-12/12/1999
T-UI, Terminal Console Launcher: https://play.google.com/store/apps/details?id=ohi.andre.consolelauncher

Offline Trotto23

  • Utente junior
  • **
  • Post: 94
  • Respect: 0
    • Mostra profilo
  • Sistema operativo:
    Windows Vista
Re:problema nell\' avvio di activity secondaria
« Risposta #3 il: 03 Maggio 2014, 16:40:02 CEST »
0
Che problema era? :)