Autore Topic: Lag dell'applicazione  (Letto 686 volte)

Offline darko

  • Nuovo arrivato
  • *
  • Post: 26
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy s4
  • Sistema operativo:
    Windows 7
Lag dell'applicazione
« il: 02 Gennaio 2014, 13:59:37 CET »
0
Salve a tutti, io ho avuto un grosso problema con la mia app: andava tutto bene, avevo finito tutto e dovevo solo cambiare l'icona predefinita in una creata da me. Allora sono andato su: 
Makeappicon - Generate app icons of all sizes in a click!
e ho caricato la mia immagine png e il servizio online mi ha creato le varie dimensioni drawable (hdpi, ldpi, xdpi, ecc.) e io le ho copia incollate nel progetto trascinandole nelle cartelle corrispondenti con eclipse aperto, e quindi hanno sostituito le png precedenti visto che avevano lo stesso nome. Il problema è che prima di mettere le nuove icone l'app andava bene, mentre adesso con le nuove icone su alcuni dispositivi (tipo samsung galaxy s4) l'applicazione "lagga" mentre su altri più deboli (tipo samsung galaxy star) va comunque alla perfezione. Eppure non ho modificato niente nel codice e comunque "lagga" su solo alcuni dispositivi (in cui di solito non lagga niente  ;-) ). Qualche suggerimento??

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Lag dell'applicazione
« Risposta #1 il: 02 Gennaio 2014, 15:17:52 CET »
0
Strano che una bitmap crei questi problemi.
Hai provato ad aprire singolarmente ciascuna bitmap e risalvarla? Magari qualcuna è corrotta o ha qualche stranezza.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store

Offline darko

  • Nuovo arrivato
  • *
  • Post: 26
  • Respect: 0
    • Mostra profilo
  • Dispositivo Android:
    Samsung Galaxy s4
  • Sistema operativo:
    Windows 7
Re:Lag dell'applicazione
« Risposta #2 il: 02 Gennaio 2014, 21:12:59 CET »
0
Ho appena provato ma niente, non è cambiato niente, l'app continua a "laggare"...non so che pesci prendere..

Offline bradipao

  • Moderatore globale
  • Utente storico
  • *****
  • Post: 4043
  • keep it simple
  • Respect: +567
    • Github
    • Google+
    • bradipao
    • Mostra profilo
  • Dispositivo Android:
    Nexus 5
  • Play Store ID:
    Bradipao
  • Sistema operativo:
    W7
Re:Lag dell'applicazione
« Risposta #3 il: 03 Gennaio 2014, 09:02:41 CET »
0
Ho appena provato ma niente, non è cambiato niente, l'app continua a "laggare"...non so che pesci prendere..

Prova a rimettere le vecchie bitmap, magari non cambia niente e la causa è un'altra.
NON rispondo a domande nei messaggi privati
Bradipao @ Play Store