Autore Topic: Problema maps v2  (Letto 513 volte)

Offline gabric

  • Utente senior
  • ****
  • Post: 613
  • Respect: +18
    • Google+
    • Mostra profilo
    • Brancato's site
  • Dispositivo Android:
    Nexus 5 / Tablet mediacom s4
  • Play Store ID:
    Brancato's+app
  • Sistema operativo:
    window7. ubuntu
Problema maps v2
« il: 24 Agosto 2013, 16:43:24 CEST »
0
Salve!
ho un app che usa le maps v2, perfettamente funzionante.
Sto sviluppando un altra app, per un test ho inserito l'api key della prima app, e ho esportato il progetto con lo stesso certificato, ma non funziona. mi viene stampato l'errore:
Codice (XML): [Seleziona]
 E/Google Maps Android API(31969): Failed to load map. Error contacting Google servers. This is probably an authentication issue (but could be due to network errors).e naturalmente vedo solo l'area grigia con i tasti più e meno

nel manifest ho messo tutto (copiato dall'altra app funzionante)
per caso c'è qualcosa connesso al package name?

codice della classe

Codice (Java): [Seleziona]
public class Mappa extends  FragmentActivity implements OnMarkerClickListener{

                LatLng STARTING_POINT;
                Marker marker;
                TextView testo;
                GoogleMap map;
                String tel;
                @Override
                public void onCreate(Bundle savedInstanceState) {
                super.onCreate(savedInstanceState);
                setContentView(R.layout.mappa);
               
                Toast.makeText(getApplicationContext(), "Caricamento mappa...", Toast.LENGTH_LONG).show();
                testo = (TextView) findViewById(R.id.tvIndirizzo);
                Intent iin= getIntent();
                String indirizzo = iin.getStringExtra("indirizzo");
                testo.setText(indirizzo);
               
                Double lat = Double.parseDouble(iin.getStringExtra("lat"));
                Double lng = Double.parseDouble(iin.getStringExtra("lng"));
               
               
                STARTING_POINT=new LatLng(lat, lng);//37.558076, 14.29023);
               
                  map = ((SupportMapFragment) getSupportFragmentManager().findFragmentById(R.id.map)).getMap();
                 try{
                       
            if(map!=null){ map.moveCamera(CameraUpdateFactory.newLatLngZoom(STARTING_POINT, 23));
                 map.setMapType(GoogleMap.MAP_TYPE_HYBRID);}
                 }catch(Exception e){
                         e.printStackTrace();
                 }
               
                marker =  map.addMarker(new MarkerOptions().position(STARTING_POINT).icon(BitmapDescriptorFactory.fromResource(R.drawable.poi)));
                 
}}

Offline Ricky`

  • Amministratore
  • Utente storico
  • *****
  • Post: 3487
  • Respect: +506
    • Github
    • Google+
    • rciovati
    • Mostra profilo
Re:Problema maps v2
« Risposta #1 il: 24 Agosto 2013, 18:56:31 CEST »
0
Devi generare un API key per ciascun package.

Offline lillogoal

  • Utente normale
  • ***
  • Post: 167
  • Respect: +4
    • Google+
    • lillosogliani
    • Mostra profilo
    • LilloNet
  • Dispositivo Android:
    Galaxy s3, Nexus 7,galaxy s advance,galaxy scl
  • Play Store ID:
    Lillonet Inc.
  • Sistema operativo:
    Windows 8,7 & Kali-Linux
Re:Problema maps v2
« Risposta #2 il: 24 Agosto 2013, 23:55:51 CEST »
0
Le api key... ma nell'altro package ti funzionava?
Chi non progetta la sicurezza , programma il fallimento! K.M

Offline gabric

  • Utente senior
  • ****
  • Post: 613
  • Respect: +18
    • Google+
    • Mostra profilo
    • Brancato's site
  • Dispositivo Android:
    Nexus 5 / Tablet mediacom s4
  • Play Store ID:
    Brancato's+app
  • Sistema operativo:
    window7. ubuntu
Re:Problema maps v2
« Risposta #3 il: 25 Agosto 2013, 03:00:15 CEST »
0
domani provo a generare la nuova apikey
comunque si certo, nell'altra app funziona perfettamente